Overview:
The user sets a File Extention as a URL, but encounters the error: Download failed when downloading the file in the Document tab of CRM iPad.
Root Cause:
This should be supported based on Documents and Attachments.
An administrator can reference a URL to a file rather than upload the actual file when creating a new document record. The file from the URL location is downloaded to the device when offline and downloadurl displays in the Keywords field. Be sure to separate the keywords with a comma. Externally sourced files behave the same as normal files on the device.
But the file only has offline in the Keywords field.
Solution:
Change it to offline, downloadurl in the Keywords field.
Related Documentation:
CRM Help Documentation: Documents and Attachments