Overview:
An email is sent to a recipient through the Approved Email functionality. An error message is encountered relating to an Id that cannot be accessed on the Sent Email record on the Failure_Msg_vod field: Failed to send because template with the ID could not be accessed on Sent Email Record.
Root Cause:
The Approved_Email_Template_vod field is null and the Sent Email record has a Failed status.
Solution:
Be sure the end-user has Field Level Security (FLS) Edit on the Approved_Email_Template_vod field in the Sent Email object in order to populate the Email Template that was utilized.
Related Documentation:
CRM Help Documentation: Configuring Approved Email