Overview:
Upon clicking on the Double Opt-In confirmation link in the Confirmation Email, the following error is shown in the browser:
Root Cause:
The issue is caused by the mismatch between the Message Identifier value located in the approvedEmailAction token of the Multichannel Routing referenced Approved Document and the Multichannel Message record.
The issue can also occur when the CRM Integration user or end-user does not have access to the Multichannel Message record or the fields, objects and record types mentioned in the Double Opt-in CRM Help.
Solution:
Be sure that the Message Identifier of the Multichannel Message record and the referenced Approved Document contain the same Message Identifier value.
Example: If the Message Identifier is 101 of the Multichannel Message record:
The approvedEmailAction token should appear as shown in the following Approved Document:
- {{approvedEmailAction[https://www.cholecap.com,101]}} - if a Landing Page (Website) is used.
- {{approvedEmailAction[,101]}} - if a Landing Page is not used.
Note #1: The comma in the second case is required.
Note #2: The token has to be placed in an href HTML tag to work.
Example:
This shows a token in the event that a Landing Page is not used:
<a href="{{approvedEmailAction[,101]}}">Double Opt-in Confirmation Link</a>
- In the event, a Landing Page (Website) URL is used in the token. Be sure to embed the following code into that website's BODY tag:
<div align="center" id="multichannelmessage"> </div>
<!-- The iFrame and Multichannel Message Page will replace the above <div> tag. Please note that the id of the <div> matches the first parameter of the constructor -->
<script>
var tag = document.createElement('script');
tag.src = "//cdnmc1.vod309.com/multichannel/veeva/js/externalrequest/embed-multichannelmessage.js";
var firstScriptTag = document.getElementsByTagName('script')[0];
firstScriptTag.parentNode.insertBefore(tag, firstScriptTag); // This function creates an <iframe> (and multichannelmessage iframe viewer) // after the API code downloads. var multichannelMessage; function onMultichannelMessageAPIReady() { multichannelMessage= new MUL.Frame('multichannelmessage', {height: '600px',width: '80%',}); }
</script>
- Be sure to complete the configuration in the Double Opt-in CRM Help.
Related Documentation:
CRM Help Documentation: Double Opt-In