Overview:
An Integration user runs the Mobile CRM Scheduled Push Notifications in Veeva Process Scheduler. After the successful run, the user does not get the Push Notification in Veeva CRM for iPad. In the Success Log, the following error message is found: No valid response from APN network for alert sending.
Root Cause:
The Integration user or the end-user do not have edit access to the AppID_vod__c field on the Mobile_Device_vod__c object.
Solution:
Be sure that the end-user and the Integration user have edit access to all fields on the Mobile_Device_vod__c object.
Related Documentation:
CRM Help Documentation: iOS Push Notifications