Overview:
When creating a call from an Events Management record, the Attendees of the event are not pre-selected as Call Attendees.
Root Cause:
If the Enable Child Account Veeva Setting is set to true, the user needs visibility to a valid Child Account record. In addition visibility to both account Ids from the Child Account and Parent Account fields is needed to have suggested event attendees show.
Solution:
Grant the user proper access to the Child Account record and to the Parent Account record.
Related Documentation:
CRM Help Documentation: Events Management