Overview:
When a user creates a new Order record and clicks on the Order Line tab in WinModern, nothing happens. The products do not appear in the Product Selector.
Root Cause:
The page layout for the affected Order record type does not have any related lists defined. Order Line is required as a related list.
Solution:
Add the Order Line related list to the affected Order page layout.
Related Documentation:
CRM Help Documentation: Configuring Order Management