Overview:
Lookup field shows the record's SFDC ID instead of its Name in My Accounts view.
Example:
In My Accounts view, the Primary Parent lookup field displays the record's 18-digit SFDC ID instead of the Name.
When the user opens the record's 18-digit SFDC ID in the browser, the following error occurs:
Root Cause:
The user does not have access to the record itself.
Solution:
In order to display the record's name in the lookup field, grant the user access to the record.
Related Documentation:
CRM Help Documentation: Account Lists and Views