Overview:
A sample limit can be defined at different levels for a given product. One of the levels is Account.
However, the existing Sample Limit for an Account is not applied when a new user disburses Samples to the same Account in CRM. The Limit value on the Call Sampling page does not match the Remaining Quantity of Sample Limit.
Root Cause:
The new user does not have access to the existing Sample Limit record.
Solution:
Be sure the new user has access to the existing Sample Limit record.
Related Documentation:
CRM Help Documentation: Sample Limits