Overview:
The Veeva CRM Multichannel Cycle Plan (MCCP) Calculation job fails with the following error:
Can't find meta data for field [OBJECT NAME].[FIELD NAME].
Root Cause:
This issue occurs when the MCCP CRM Integration User not able to find the Object or the Field indicated in the error message.
This can be due to the following reasons:
- The MCCP CRM Integration User has no Field Level Security (FLS) for the field mentioned in the error.
- The MCCP CRM Integration User has no Create-Read-Update-Delete (CRUD) object permission for the indicated object used in the Channel Object field of the relevant MC Cycle Channel record.
- The MC_Cycle_Channel_vod__c records have incorrect Channel_Criteria_vod__c specified. This may occur after an incorrect dataload, or the Channel Object field was adjusted incorrectly in a manual way.
- The object indicated in the field MC_Cycle_Channel_vod__c.Channel_Object_vod__c is incorrect. This occurs in case there is an incorrect custom picklist value defined in the Channel Object. Custom picklist values are not supported.
Solution:
- Verify the OLS, FLS permissions for the CRM MCCP Integration user. Provide these permissions in the event they are not given.
- Verify the Channel Object values of the existing MC Cycle Channel records that they are consistent with the picklist values listed below.
- Do not add any custom picklist values into this object, do not leave inactive values in this object, delete them. Ensure to check if any MC Cycle Channel records have this custom field in use, and be sure to replace them with a valid out-of-the-box (OOTB) picklist value.
Related Documentation:
CRM Help Documentation: