Overview:
A Sample Limit Transaction record is created along with the creation of a Sample Limit from a Sample Limit Template. An additional Sample Limit Transaction is created when disbursing Samples in CRM. It is not related to a Call record and the value of Quantity To Disburse is null.
Root Cause:
A user-defined custom workflow rule performs a field update on the Call Sample. Due to this, the Call Sample triggers are run a second time.
Please refer to this article: Triggers and Order of Execution.
This eventually results in a Sample_Limit_Transaction_vod record being inserted using the trigger VEEVA_BEFORE_SAMPLE_LIMIT_AUDIT on Sample_Limit_vod.
Solution:
The user needs to either disable the custom workflow rule or modify it accordingly to solve this issue.
Related Documentation:
CRM Help Documentation: Sample Limits
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