Overview:
There is no activity information tracked under the Open and Click Statistics section in the Sent Email detail page, such as Opened, Total Opens, Total Clicks even though the email is opened by the end-user.
Root Cause:
The Health Care Professional (HCP) opts into receiving Approved Emails but does not have any subsequent email activity associated with the HCP's account information.
As a result, the sent email record has the field value Activity_Tracking_Mode_vod__c = Anonymous_vod. It means the Account has email activity tracked anonymously.

Solution:
In order to track email activity, the HCP should consent to receive emails and allow tracking the activity of those emails on the Consent Capture screen.
Related Documentation:
CRM Help Documentation: Tracking Activity in Consent Capture