Overview:
When the user tries to add attendees to Event in CRM, the following error occurs:
Error: VOD_EM_ATTENDEE_AFTER_INS_UPD:execution of AfterInsert caused by:System.NullPointerException.
Root Cause:
Even though the user is assigned record types of EM_Attendee_vod, the default record type is not specified yet.
Solution:
Specify the default record type on the User's profile:
- Open the user's profile.
- Scroll down to the Custom Record Type Settings section.
- Locate the EM_Attendee_vod, click the Edit button and then specify the default record type. For example, Attendee_vod.
Related Documentation:
CRM Help Documentation: Adding Attendees to an Event