Overview:
Error: xxx.visual.force.com says - When opening an Event in CRM
Root Cause:
The user does not have access to the Event record.
Solution:
Be sure the user has access to the Event record.
One method is to adjust the Sharing Settings. Navigate to Setup --> Administration Setup --> Security Controls --> Sharing Settings, select Event and then adjust the Sharing Settings accordingly.
Please refer to this guide if needed: Create Sharing Rules
Related Documentation:
CRM Help Documentation: N/A