Overview:
A user receives the following error on sync:
Error: Field name provided, Mobile_ID_vod__c does not match an External ID, Salesforce Id, or indexed field for xxx(field name).
Root Cause:
The field is from a custom object and the Mobile ID field on the custom object is not set as Unique and External ID.
Mobile ID is used in Custom Objects as a unique identifier for records created Offline.
Solution:
Mark the Mobile ID as Unique and External Id. This should remove the error.
Related Documentation:
CRM Help Documentation: N/A