Overview:
In the Approved Email Administration console in CRM, the integration process is failing and the following error appears: Internal Server Error: java.lang.NullPointerException.
Root Cause:
If Events Managements is being used and there are EM_Catalog_vod__c records in the org where the Name_vod__c field is blank, the integration fails.
Solution:
Populate the Name_vod__c field on the EM_Catalog_vod__c records and run the Approved Email Process again or wait for the scheduled process to be executed.
Related Documentation:
CRM Help Documentation: Using Approved Email for Events Management