Overview:
To start an ad hoc CoBrowse session, the user navigates to the Account’s detail page and selects the Start CoBrowse button. When trying to send an invitation through Approved Email, an error displays: At least 1 email recipient is required to send an email.
However, this is working normally if the user first creates a Call and then sends the invitation.
Root Cause:
When the user clicks the Start CoBrowse button on the Account detail page, this creates a Call using the default CoBrowse record type. This is defined in the COBROWSE_DEFAULT_RECORD_TYPE_vod Multichannel Setting.
The user does not have access to that record type.
Solution:
- Navigate to Setup --> Develop --> Custom Settings --> Multichannel Setting.
- Be sure the user has access to the default CoBrowse record type defined in COBROWSE_DEFAULT_RECORD_TYPE_vod.
Related Documentation:
CRM Help Documentation: Using CoBrowse