Overview:
The customer org has configured the Edit Data Change Request (DCR) buttons for Accounts and Addresses in Lightning. It also occurs when clicking the Edit DCR button. The following error occurs:
Lightning components require My Domain. Please contact your system administrator for more information.
Root Cause:
The error occurs when the customer org is not configured with My Domain.
My Domain must be deployed in the customer org in order to use Lightning components. This includes components in Lightning tabs, Lightning pages, as standalone apps, as actions and action override, as custom Lightning page templates, or elsewhere in the org.
Solution:
Configure My Domain according to the Salesforce guide that is included in the Related Documentation section of this article.
Related Documentation:
- CRM Help Documentation: Getting Started with Veeva CRM and Lightning
- Salesforce reference guide: Salesforce My Domain