Overview:
Invitations are sent for an Engage Meeting Call. However, the error message: x of x attendees have not been invited displays in the My Schedule page.
Root Cause:
After sending invitations, a user modifies the Call_Datetime_vod__c field of the Call object.
For an Engage Meeting Call, the Scheduled_DateTime_vod__c of the Remote Meeting is updated anytime the user updates the Call_Datetime_vod__c field. This is effectively rescheduling the Call and Remote Meeting. In the meantime, this also causes the CreatedDate of Sent Email to be earlier than the Scheduled_DateTime_vod__c on the Remote Meeting record.
For any Engage Meeting Call where the CreatedDate of Sent Email is earlier than the Scheduled_DateTime_vod__c on the Remote Meeting record (or there is no Sent Email record), the error displays.
Since the user reschedules the meeting, it is expected that a new email needs to be sent out so the warning message is displayed. Remote Meetings are typically tied to the Call Datetime field.
Solution:
Avoid adjusting the Call_Datetime_vod__c field of the Call object after sending the invitations to prevent this error message from occurring.
Related Documentation:
CRM Help Documentation: Sending Engage Meeting Invitations via Approved Email
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.