Overview:
When country-specific disclaimers are used in Events Management, the disclaimer that is added to the relevant Signature_Page_vod record is not appearing on the Sign-In Sheet.
Root Cause:
When an Event is created, the selected Country is recorded on the Medical Event stub. The Medical_Event_vod.Country_vod field is populated using EM_Event_vod.Country_vod upon the creation of the event record.
The country-specific Sign-In Sheet disclaimers from the Signature_Page_vod.Disclaimer_Text_vod field are displayed the following way:
Medical_Event_vod.Country_vod = Signature_Page_vod.Disclaimer_Country_vod
AND
Signature_Page_vod.Signature_Page_vod equals Medical_Event_vod
If the end-user does not have access to the Medical_Event_vod.Country_vod field, the Signature Page record cannot be matched with the Event record.
Solution:
Do the following:
- Grant the end-user at least Field Level Security (FLS) read access to the Medical_Event_vod.Country_vod field.
- Clear the Veeva Cache.
- Refresh the database of the Veeva CRM for iPad application.
Related Documentation:
CRM Help Documentation: Country-Specific Sign-In Sheet Disclaimers