Overview:
In order to display some Address fields on the New Account Wizard, the user marks them as Required on the Address page layout. They are also marked as Required on the General Options of the field detail page. However, the Address fields cannot be added in the New Account Wizard.
Root Cause:
The user has Read permission to the Address object only. No changes can be made.
Solution:
Grant the user Edit permission to the Address object.
Related Documentation:
CRM Help Documentation: New Account Wizard