Overview:
If an Approved Document that is used in Events Management is updated in Vault, the related Event Material record is not referencing the latest version. This occurs even if a Full Refresh is made in the Approved Email Administration Console.
Root Cause:
The behavior is currently expected.
Event Materials for an Event only get added or updated when the Event is initially created (if added by an Event Rule) or if the Topic Material is modified on the Event. They do not get re-calculated if the referenced Approved Document gets updated.
Solution:
The solution is to manually update each Event Material record by changing it to use the correct template.
Related Documentation:
CRM Help Documentation: Using Approved Email for Events Management