Overview:
When trying to edit a report, a user sees the following error: Error processing this report because it references inaccessible field(s) {Field being referenced}.
Root Cause:
There can be two different root causes:
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The error can occur because a field included in the Displayed Columns in the report has a Default Security as Hidden:
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If the inaccessible field referenced is one of the following fields:
- activation_date_sys
- inactivation_datesys
- send_welcome_email_sys
The permission to Manage User Object needs to be enabled on the user's Security Profile who ran the report. These fields are protected resources of the User Object and are only accessible when the Manage User Object permission is given to the Security Profile.
Solutions:
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For updating a hidden field, an Admin is required to do the following:
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Go to Admin --> Configurations --> Document Fields --> [Document Field].
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Click the Edit button.
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Update the Default Security from Hidden to other settings.
- Or, the admin can add a Security Override, which is not Hidden, to the expected users who have access to open that report.
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- For the Manage User Object scenario, an Admin needs to follow the breadcrumb trail and enable the Manage User Object permission on the user's Security Profile.
Navigate to: Admin --> User & Groups --> Permission Sets --> Security Profile --> Admin --> Users --> Manage User Object.