Overview:
After creating users successfully with the Read-Only security profile in a Vault, the users cannot see the Vault in their accounts. They are not able to access the Vault. Why does this happen?
Root Cause:
The Vault is currently in Configuration Mode, which locks non-Admin users out of a Vault when attempting to complete certain configurations. Users with the Vault Owner or System Admin security profile can continue to work in the Vault through the UI and the API.
Since the users are non-Admin users, they cannot see the Vault in their account.
Solution:
To make the Vault visible for these users, the Configuration Mode needs to be disabled. To disable the Configuration Mode, an admin needs to do the following:
- Navigate to Admin --> Settings --> General Settings.
- Uncheck the Configuration Mode Active option under Configuration Management.
Related Documentation:
Vault Help Documentation: About Configuration Mode