Overview:
To display CLM presentations in an Engage Meeting hosted in the CRM Engage app, users must first download the presentation either before or during the Engage Meeting.
However, a presentation cannot be downloaded in the CRM Engage App in CRM Online and the error below can be found in the CRM Engage APP log:
C:\Users\[User Name]\AppData\Local\VeevaCRMEngage\Logs\infoLogFile.txt.
2020-08-10 17:46:11.5911|201.12.1228.0|ERROR|VeevaEngage.Common.Applications.Services.FileSystemService.extractFile|extractFile C:\Users\[User Name]\AppData\Local\VeevaCRMEngage\app-201.12.1228\[Account Name]\Media\xxxxxxxxxxxxxxxxxx\[Media File Name]\_global\images\con.eps Error FileStream will not open Win32 devices such as disk partitions and tape drives. Avoid use of "\\.\" in the path.
Root Cause:
Reserved characters or names are used in the name of the zip file in the Key Message.
For example:
The following reserved characters:
- < (less than)
- > (greater than)
- : (colon)
- " (double quote)
- / (forward slash)
- \ (backslash)
- | (vertical bar or pipe)
- ? (question mark)
- * (asterisk)
The following reserved names for the name of a file:
CON, PRN, AUX, NUL, COM1, COM2, COM3, COM4, COM5, COM6, COM7, COM8, COM9, LPT1, LPT2, LPT3, LPT4, LPT5, LPT6, LPT7, LPT8, and LPT9.
Solution:
Use valid characters or names in the name of the zip file.
Related Documentation:
Online Help Documentation:
Windows Help Documentation: Win32 Device Namespaces