Overview:
The Child Account View in the Scheduler of CRM My Schedule does not display correctly. It appears that all Child Accounts are displayed as blue lines. This appears as shown:

Root Cause:
The user does not have Field Level Security (FLS) on the Parent_Child_Name_vod__c field of the Child Account.
Solution:
Grant the user FLS on the Parent_Child_Name_vod__c field of the Child Account.
Refer to this guide about FLS if needed: Field-Level Security.
Related Documentation:
CRM Help Documentation: Working with Child Accounts