Overview:
The user cannot create a Call Objective from a Suggestion in CRM Online. An error displays: 1 Call Objective/s failed to create.
However, the Call Objective can be created in CRM iPad.
Root Cause:
The user does not have Field Level Security (FLS) on the On_By_Default_vod field of the Call Objective.
Solution:
Grant the user FLS on the On_By_Default_vod field of Call Objective.
Refer to Field-Level Security Salesforce Documentation page.
Related Documentation:
CRM Help Documentation: Suggestions Overview