Overview:
The Name field is not populated and the drop-down menu is also empty for Follow-up Activities when recording a call for a Business Account.
The field is correctly populated when scheduling a call for a Person Account.
Root Cause:
Follow-up Activities can be created only for Person Accounts currently.
Solution:
This is working as designed.
The customer should submit an Enhancement Request in the Product Support Community to suggest this change.
Related Documentation:
CRM Knowledge Base Article:
Online CRM Help Documentation: