Overview:
Clone and Edit buttons are not available for Engage Ratings Dashboard in CRM.

Root Cause:
This dashboard is created in Salesforce Lightning. When a dashboard is created in Salesforce Lightning, the user does not see the Clone and Edit buttons in Salesforce Classic.
Solution:
If the user wants to edit or make a copy of this Dashboard, the user can switch the Salesforce UI to Lightning. Use the Edit or Save As button from the Dashboard.

Related Documentation:
CRM Help Documentation: N/A
Send us your feedback: We are always looking for feedback to help improve our Knowledge Base! Please let us know if this article is helpful or provide feedback on how we can improve your experience by clicking here.