Overview:
When creating a new Event Business Rule record the following error appears:
Error: Invalid Data.
Review all error messages below to correct your data.
These changes were not applied because they resulted in duplicate rules or rule configurations: <Record Name>
Root Cause:
An Event Business Rule record is not saved in create or edit mode if there is an existing event Business Rule record that:
- Has the same record type, AND
- Has the same Run Rule on Event Action, AND
- Has the same unique rule-specific parameter inputs
The unique rule-specific parameter inputs are:
- Attendee Account Type
- Per Event Topic
- Warning Type
Solution:
Review the data based on the above conditions to ensure that the new Event Business Rule record is unique.
Related Documentation:
CRM Help Documentation: Event Business Rules