Overview:
The Submit button is missing from the Medical Inquiry Fulfillment Response (MIFR) page Online.
Root Cause:
The --nso Section Signal is on the Call2_vod object Page Layout for the Medical_Inquiry_Fulfillment_vod record type, in the section containing the action zvod_buttons. This Section Signal causes the Submit button not to display Online.
Solution:
Remove the --nso Section Signal from the appropriate Call2_vod Page Layouts and clear the Veeva Cache.
Background:
The Medical Inquiry Fulfillment Response page Online is comprised of two separate Page Layouts: The Medical_Inquiry_Fulfillment_Response_vod object Page Layout, and the Call2_vod page layout for the Call that the MIFR is part of.
There is a specific Call2_vod record type for MIFR calls - Medical_Inquiry_Fulfillment_vod - and there can be specific Page Layouts for that Call record type for different Profiles.
The --nso Section Signal works the same on the Medical_Inquiry_Fulfillment_vod Call record type as it does for other types of Calls: when placed in the Page layout section that contains zvod_buttons, it prevents the display of the Submit button Online.
Related Documentation:
CRM Help Documentation: