Overview:
The products are already assigned through the My Setup page. When clicking the Add Other button, the user is still not able to search any products in the Detail Selector of Call Report Page in CRM Online. The favorite products are not displayed either.
Root Cause:
The user does not have Field-Level Security (FLS) on the Controlled_Substance_vod__c field on object Product_vod__c.
Solution:
Grant the user at least Read FLS on the Controlled_Substance_vod__c field on object Product_vod__c.
Please refer to the Salesforce help document if needed: Field-Level Security
Related Documentation:
CRM Help Documentation: Configuring Call Reporting
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