Overview:
Upon Running the Mass Assignment job in Territory Utiltiies, the Territory VoD is not populated as expected in Veeva CRM. Several other pieces of misconfiguration are ruled out.
Root Cause:
The issue may be caused because there are too many territory values in the Territory VoD field. Both the Territory VoD and Territory Test VoD fields have a character limit of 255 (Text).
Solution:
- Modify the Address, Account, Brick to Terr, or Zip to Terr data to assign a fewer number of territories.
- Decrease the length of the Territory Names.
- Generate assignments explicitly and use Account Territory Loader (ATL).
- Use Veeva Align.
Note: The issue may be noticed by locating cropped strings of the territory names or double semi-colons in Territory VoD / Territory Test VoD.
Related Documentation:
CRM Help Documentation: