Overview:
On the Online platform, none of the custom Multichannel Activity records are visible for a particular Account.
Root Cause:
The required fields are not populated on the Multichannel_Activity_vod records. All the records referencing a particular Account must be populated correctly. If there is one record that is incorrect, then none of the existing activities are displayed.
Solution:
The following fields on the Multichannel_Activity_vod records are required for the custom activities to display on the Account Timeline and Multichannel Home Page:
- RecordTypeId (must be the custom record type)
- Start_DateTime_vod
Related Documentation:
CRM Help Documentation: Viewing Multichannel Activities on the Account Timeline