Overview:
Upon trying to search for an Account name using the Can't Find the Account link, in the result list, the Account name is missing. Only addresses appear. The Can't Find the Account link is also referred to as the Outside Territory Search feature of the Veeva Align Enhanced Feedback functionality on CRM for iPad.
Root Cause:
The Formatted Name field is not populated on the Account records in CRM, in turn in Align.
Solution:
Ensure the formatted_name__aln field is populated for all account__aln records in CRM, and in Align via the CRM-Align Integration.
This has to be achieved in Align by mapping the formatted_name__aln Align field of the account__aln object to the formatted_name_vod__c CRM field of the Account object.
Once the mapping is configured, a Full Account Import from CRM task has to be performed. This can be achieved simply by utilizing the Account Process Monitor record.
Be sure to run Recalculate Territory Data on the Model Field Force.
Related Documentation:
Align-CRM Help Documentation:
Knowledge Article: