Overview:
When saving a new Order and adding Order Lines with some quantities, the Payment Term is calculated and can be modified. But after editing the saved Order, the Payment Term can not be changed, appears read-only.
Root Cause:
After returning back to a saved order to edit it, the Payment Term on Order Header is locked. It appears read-only until a second Product is entered, or existing Product fields are modified. What is actually happening here is the Pricing Rules have not run and the system does not know which Payment Terms to display.
Solution:
This is working as designed. Adding another Product or modifying existing Product fields triggers Pricing Rules to run and Payment Terms become editable.
Related Documentation:
CRM Help Documentation: Payment Terms