Overview:
There is a private Sharing Setting for the EM Catalog object and a Sharing Rule based on the user's Country. By default, the EM Catalog record is not shared with the user.
When clicking on the Generate Invitations button, The record is available among the Invitation Templates. This occurs even if the user does not have access to the EM Catalog Template.
Selecting the Template the following errors occur on different platforms:
- Online: Please select a template from the left-hand side to see a preview.
- iPad: Attachment not found for Catalog template: {Record ID}
Root Cause:
Event Material is created regardless of the sharing to the EM Catalog and the EM Catalog Template is not pre-filtered based on Sharing Rules.
Solution:
This is working as expected. In case the EM Catalog Template only applies to a specific group of users based on the user's Country, the recommendation would be to apply a Country Override on the Event Rule in the Event Configuration so that this Event Material would not be created in the first place.
Related Documentation:
CRM Help Documentation: Managing Event Materials