Overview:
Upon accessing the Territory Feedback tab on CRM for iPad, the following error occurs:
Feedback Unavailable, Service is currently unavailable. Try Again later.
Online, the Feedback functionality works correctly. Attempting to use Legacy Feedback - Align Territory Feedback Mode = 1 - does not result in this error on CRM for iPad.
Root Cause:
The issue may be caused by the following reasons:
Issue #1:
Only particular Model Territories are set in the Feedback (Review) Lifecycle State, not the entire Modeling Project, which remains in draft. Enhanced Feedback (Align Territory Feedback Mode = 2) currently requires the Project and all of its relevant child records (Model Territory and/or MC Cycle) to be in the Feedback (Review) State.
Issue #2:
There are (Model) Approval Mapping Records whose (Model) Field Force lookups are not populated.
Issue #3:
The Align version is not up to date in the Territory Settings record, due to the lack of the Push to CRM or Import from CRM jobs.
Solution:
Issue #1:
Change the lifecycle state of the Modeling Project to Feedback Review, ensuring that all of the relevant child records (Model Territory and/or MC Cycle) are in the Feedback (Review) State.
Issue #2:
Remove the (Modeling) Approval Mapping Records that are in this state.
In either of the cases, on the Modeling Field Force, run Recalculate Territory Data.
Issue #3:
Ensure to run Push to CRM or Import from CRM jobs.
Related Documentation:
CRM Help Documentation:
Align Help Documentation:
Knowledge base:
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