Overview:
When attempting to view a published Event Survey through CRM, an error occurs: This survey is only available on the following channels: Approved Email.
Root Cause:
Published Event Surveys can only be used with the Approved Email channel. This error displays when a user attempts to access a published Survey Target record directly.
Solution:
It is expected behavior that Event Attendees and Speakers should complete surveys through survey link tokens received using Approved Email.
Related Documentation:
CRM Help Documentation: Surveys in Events Management