Overview:
After adding a new custom button on the EM_Event_vod object and refreshing the metadata, the button does not appear as selectable when creating a new Event Action record.
Root Cause:
The administrator who runs the Event metadata refresh does not have Record Type access to Weblink_vod on the Metadata_Definition_vod object. The custom button is created as a Metadata Definition record with a Weblink_vod Record Type.
Solution:
The EM_DATA_ADMIN_VOD Permission Set contains the necessary Record Type accesses on the Metadata_Definition_vod and Metadata_Translation_vod objects. Assign this Permission Set or its clone to the Admin who is running the Event metadata refresh.
Note: Every major version of Veeva Events Management updates these permission sets to include permissions to the newest features. New feature deployment involves change management and training. For that reason, Veeva recommends cloning the Veeva-delivered permission sets and enabling the features that you want to use.
Related Documentation:
CRM Help Documentation: Defining Event Flows