Overview:
Attachments cannot be downloaded in Lightning online and/or offline via the Go Online functionality, only in classic mode.
The following error appears when clicking Download of an Attachment:
-
Unable to Finish Processing Request
An error has occurred while processing your request. The Salesforce support team has been notified of the problem. If you believe you have additional information that may help in reproducing the error, please contact support@salesforce.com. Please indicate the URL of the page you were requesting as well as any other related information. We apologize for the inconvenience. Thank you again for your patience and assistance. And thanks for using salesforce!
Error ID: Data Not Available
Root Cause:
Two main issues can cause this behavior:
- The org's My Domain settings are not full
- XSS Protection and Content Sniffing protection are not enabled
Solution:
- Open Setup.
- Open Company Settings --> My Domain.
- Confirm if My Domain is already enabled in the org.
Example: on the screenshot below, it can be seen that this org has the feature enabled based on the name of the domain listed.
- Open Security --> Session Settings.
- Enable XSS protection.
- Enable Content Sniffing protection.
- Save the changes.
- Clear Veeva cache.
- Refresh the user offline (in case of Go Online errors on the iPad).
Related Documentation:
- CRM Online Help: SFDC My Domain
- Salesforce Documentation: Salesforce CRM Services Platform Security FAQs