Overview:
Why are Country Code Specific Approved Notes Monitoring Rules not Picking up Violations in Veeva CRM?
Root Cause:
The issue is caused by misconfiguration, the Country_Code_vod__c field must be placed on the relevant page layout of the User Object and must be populated with the correct Country Code.
Solution:
Place the Country_Code_vod__c field on the relevant User Page Layout, populate it with the correct Country Code value and clear the Veeva Cache.
Related Documentation:
CRM Help Documentation: