Overview:
Product-dependent picklist is disabled in Call Discussion section in CRM Online. Even though the picklist values are available in the Preview window when selecting a relevant product.
Root Cause:
The product name value defined in zvod_Product_Map_vod does not match the actual product name.
Solution:
Ensure the picklist values in zvod_Product_Map_vod on the Call2_Discussion object are active and match all potential detail products. The picklist values of the zvod_Product_Map_vod field must match the names of all potential detail products.
Related Documentation:
CRM Help Documentation: Customizing Product Discussions on the Call Report