Overview:
An Event Attendance Rule is in use.
The attendance of the selected Attendee record is equal to the Limit Quantity.
The rule is fired without going above the Limit Quantity.
Root Cause:
This is working as designed.
The attendance checking in the background has a < (less than) operator instead of <= (less than or equal) between the EM Attendee records and the Limit Quantity.
Solution:
Increase the Limit Quantity on the Event Attendance Rule(s) or delete any of the existing EM Attendee records to meet the criteria.
Related Documentation:
CRM Online Help: