Overview:
Despite the User being able to connect, the API call gives no results.
Root Cause:
The affected User is using a Customer Community Plus license that has limited capabilities (cannot even access Salesforce directly).
Order API requires a Salesforce Platform license and it is not working with external users.
Solution:
The affected User needs to have a Salesforce Platform user license in order to see the results.
Related Documentation:
SFDC Documentation: User Licenses
CRM Help Documentation: Veeva CRM APIs for Order Management