Overview:
Some text on certain records contain violations. However, these violations are not flagged and Monitored Text records are not created as expected after running the Approved Notes process.
Root Cause:
There are several possible reasons Monitored Text records are not created:
- Required permissions are missing.
- The Country_Code_vod field on Monitoring_Rule_vod__c records are populated, however, the user who last modified the record, that contains the violation, does not have the same Country_Code_vod populated or the user does not have Country_Code_vod populated.
- Custom triggers exist on the Monitored Text object that may block the record creation.
Solution:
To resolve this issue:
- Grant all required permissions. Optionally, this feature can be enabled by assigning AN_ADMINISTRATOR_VOD or AN_COMPLIANCE_USER_VOD permission sets to users accordingly.
-
Per the design, when a monitoring rule's Country_Code_vod field is populated, the rule only runs against records where the user who last modified the record has the same country code as the monitoring rule.
So when creating country-specific monitoring rules, ensure the user who last modified the record has the same country code. Or clear the Country_Code_vod on both the monitoring rules and the last modified user.
- Revise the custom triggers to ensure Monitored Text records can be created correctly.
Related Documentation:
CRM Help Documentation: