Overview:
A custom Account View is created and synced on the CRM for iPad. The record number is 0 offline but the View has data online.
Root Cause:
The View has a comma-separated list in its WHERE clause so it is evaluated in a different way offline.
Solution:
Do not use multiple values in the same WHERE clause.
- Enter only one value per line. This way more criteria lines will exist.
Note: Because of the AND relation between the lines, the clauses may need to be re-designed.
or - Separate the values with a "%" character in case of some operators like "contains" or "does not contain".
Related Documentation:
Online CRM Help: Account Lists and Views