Overview:
When searching using Lookup, the correct result is not appearing, even though the search term entered matches the displayed name of the item being searched for. Wildcard searches will still display the result as expected.
Root Cause:
One potential cause of this issue is incorrect use of whitespace within the field being searched. When multiple whitespaces are used in a text or picklist field, Salesforce only displays a single space. For example, if the name of an Account is entered as "Dreloth Hospital":
The name will display as "Dreloth Hospital" in Salesforce.
Searching in Lookup for "Dreloth Hospital" will not return results; however, "Dreloth Hospital" will.
Solution:
1. Open the record to be searched.
2. Edit the field being searched (for example, Name) on the record to remove any extraneous whitespaces.
Related Documentation:
Salesforce Documentation: Considerations when multiple spaces are used in Text or Picklist fields