Overview:
Filters narrow the scope of a report. A value of a picklist field is made Inactive, but it is still selectable in the report filter.
Why does the Inactive picklist value still appear in the report filter?
Root Cause:
The Allow inactive picklist values to be used in report filters option is selected in the settings.
Solution:
An admin needs to deselect the Allow inactive picklist values to be used in report filters option by navigating to Admin --> Settings --> General Settings.
Related Documentation:
Vault Help Documentation: Inactive & Deleted Picklist Values