Overview:
The user is not prompted to select a Record Type when creating a Survey in CRM Online. Instead, the Survey editing page is opened directly.
Root Cause:
It is because the user sets an option to automatically insert the default record type when creating records. By using this setting, the user is no longer prompted to select a particular record type.
Solution:
- Log in as the user, from the personal settings, enter Record Type in the Quick Find box, then select Set Default Record Types.
- Uncheck the selection for the Survey object if needed.
Related Documentation:
Salesforce Help Documentation: Set Record Type Preferences