Overview:
A User object is searchable in Salesforce Classic. However the same functionality is not available in Lightning Experience (LEX).
Root Cause:
When Chatter is disabled on Org level and Profile level:
- People User Tab is not available in Lightning
- People(Users) is missing from Global Search Bar and People is not searchable at all in LEX
Solution:
In order to make the User object searchable in Lightning, the Admin needs to enable Chatter functionality.
Related Documentation:
SFDC Help Documentation: 'People' Tab is not visible in lightning when chatter is off (Org level / Profile level Chatter off